Resolved
The issue impacting poll publishing and response times has been resolved and polls should now be completing as expected. We will continue to monitor for any unusual behavior.
Investigating
Some surveys are having issues getting launched and filling responses.