Resolved
We have deployed a fix and full functionality should now be restored. Please contact us if you continue to experience issues completing purchases.
Investigating
We are currently experiencing an issue with our checkout service. Purchases may not complete during this time. We are investigating and hope to resume full functionality shortly.